Prerequisites

Prerequisites

Before you install, check the supported platforms.

The Red Hat installation uses the RPM package.

Check OpenSSL dependency

For Red Hat Enterprise Linux version 6.0, Couchbase Server RPM performs dependency checks for OpenSSL using pkg-config . Verify that this file is available and install it if needed:


root-> sudo yum install -y pkgconfig 

Upon successful installation, the following output appears:

Loaded plugins .... Installed: pkgconfig.x86_64 1:0.21-2.el5 Complete!
      

Install OpenSSL 098e

For Red Hat Enterprise Linux version 6.0 and later, install a specific OpenSSL dependency by running:


root-> yum install openssl098e

Some users cannot install openssl098e with this command without having administrative privileges. In such case put the contents of the lib64 directory into opt/couchbase/lib :

  1. Download openssl098e-0.9.8e-17.el6.centos.2.x86_64.rpm .
  2. Go to the directory where you extracted Couchbase Server: cd opt/couchbase .
  3. Extract the openssl098e RPM:
    rpm2cpio
    openssl098e-0.9.8e-17.el6.centos.2.x86_64.rpm | cpio --extract
    --make-directories --no-absolute-filenames
  4. Move the extracted files to the /lib directory for Couchbase Server: mv usr/lib64/* lib/